Thor pro not charging

Hi all! I got a problem with my Thor pro. It stopped charging and anything I tried not working.
I also tried to reflash firmware but smartwatch seems to be died…
Any help please?


My sons thor pro went the same way . We were convinced it was the watch and it turned out to be the charger . Are the two connecting okay ? If ours isnt forced down into charger it wont charge . It has to be held tight down with a lot of force . I know its a long shot but worth a go

You might want to check the charging dock with a voltmeter, if its ok, you might need to press the watch on the charging dock with your fingers, just untill it shows a charging animation, if its on, then try to release your finger from it. If the charging animation turned off, then the connection between those two is the problem.
If this the case, it was like mine, all i need to do was find a tissue paper, fold it an put it between the camera lens and the charging dock (the side of the watch).

1 Like

It’s the battery. It’s like a ball…
Anyone know where can I buy a new one?

1 Like

be patience let the battery to discharge if its no working open the watch an clean the pins in and out use like small flat screw driver and scrapper a little bit.

Does anyone know where can I buy a new battery?

would this work:


Are you sure? Thanks