**FIXED** Volume for the mic is extremely low

Cant seem to find an option to turn the mic volume up, is this a factory error? Would bluetooth headphones improve the mic volume? I can hear them load and clear but they can only hear a very faint wisper

Please helo, it would be much appreciated. I know some of you are Kospet pros on here, I’m sure you could guide in some way. Trying to switch from phone to watch, but thats impossible with this low mic volume

Its a Kospet Optimus Pro 32 with the little hole in the back, so its the updated version

I moved your post in the Kospet section. Please make sure that you are using the right section for your posts.

Ok, fair enough. Thought it would be the right section, roundwatch section that is. Thank you

You seem to be a pro around here, no advice how to fix this or anyone you know? Because if its a manufacturer error I should probably return ASAP… kinda panicky

Well, I have the same watch and it’s working fine. I think it’s a hardware problem. Try to return.

My intended use was to use earphones for calls and music, so I’ll give that a go first. Otherwise I dont really care. But Google assistant voice thing works perfect, odd

Ok, make sure that you run the latest Firmware version. Go to watch settings and check if there are some updates.

1 Like

Yep, firmware is up to date. Also sent Kospet an email, are they reliable when it comes to customer service?

Who did you buy it from ? Thanks

1 Like

Sorry for the delay. I bought it from Fasttech. I’ve had to return stuff to them before, they’re really good for refunds and returns… its just the wait is the pain in the arse

In this case you have to contact the seller first.

1 Like

Yeah, for sure. Thats usually what I do. I just thought I’d email Kospet see what they say about it, idk… kinda pissed spending 155 euro on a broken device. I’ll grab a pair of bluetooth headphones ASAP

1 Like

Issue fixed!! I emailed Kospet and they suggested factory reset, fixed it… thankfully

Cheers

That was the first tip we gave you, I thought…
Edit: no, I missed that! Sorry for that, this should always be one of the first things you should try. But I didn’t told you, my mistake, sorry!

1 Like

Nope, you just suggested its a hardware issue and return. Too much gin last night? lol jk

2 Likes

I am having the same issue on my Kospet…resetted many times but no improvement. Weird…it wasn’t so low first times.