TWRP and ROOT for the LEMFO LEM8

NOTE: You do this at your own risk and I will not be held responsible if something goes wrong

I have managed to root the LEM8 and port a TWRP into the LEM8’s recovery.img

I used Carliv’s Android Image Kitchen for Windows to port the TWRP from the LEMFO LEMX.

The LEMX TWRP was created by iscle and is posted at:

I used an Android Mobile Phone and Magisk Manager to patch the stock boot.img to give root

The root method can be found here: /thread/3259/root-lemfo-lem8-watches

I then used the SP Flash Tool to flash the TWRP recovery.img and the patched boot.img into my LEM8.

My LEM8 has the Z29-LEM8-V1.3 ROM installed. I downloaded it from here: /thread/2937/lemfo-lem8-z29-m6739-16gb

NOTE: the header states that it is the Update v1.2 but it is actually Update v1.3

When I rebooted the watch, it went straight into the normal face mode (no TWRP).

So, I used adb reboot recovery to get into TWRP and was successful.

I also downloaded and installed RootChecker by joeykrim and Reboot by Petrus from the Play Store to check if I had root and to boot into recovery.

I have uploaded the following files and folders to Mega:
Folder – contains SP Flash Tool
Files – boot.img – patched with Magisk Manager to give root
recovery.img – the TWRP img file
MT6739_Android_scatter.txt for SP Flash Tool

The download is given below.

• Turn off watch
• Place it on the charging plate with USB NOT connected to your PC
• Download and unzip LEM8 V1.3 TWRP from Mega
• Locate and start SP Flash Tool
• Locate and load MT6739_Android_scatter.txt into the flash tool
• Click on download
• Insert the USB cable into your PC
• The bottom window will flash a few times and a tick will come up to indicate success.

Note: If you want to go back to stock, use the stock recovery.img and boot.img and flash as above. By only flashing the boot and recovery you should not lose any settings or apps etc.



Thanks, Enviro8.  Since I already had root, I tried your recovery.img file combined with a boot.img file I had made previously with Magisk and it worked perfectly. 

Feb 18, 2019 6:16:21 GMT jlc said:

Thanks, Enviro8.  Since I already had root, I tried your recovery.img file combined with a boot.img file I had made previously with Magisk and it worked perfectly. 


It is always good when some one else has success.  Then you know that it didn’t occur by accident.

BTW I am currently investigating another form of TWRP with a different style and will post it if I am successful

As a note I am having difficulty in getting root and TWRP for the the LEM7 (MT6739 ROM) by this method but have been successful using another method.

I am still exoerimenting.

I just posted the “built from source” official LEM8 TWRP recovery from the OpenWatch team member iscle

Here /thread/2736/lemfo-lem8-model-november-2018?page=15&scrollTo=32732

I need the V1.4 ROM version someone had the link?

The V1.4 ROM is an OTA update.

It is not yet available as a program flashible with SP Flask Tool as V1.3 is on this site

If your watch does NOT have TWRP installed (and/or possibly NOT rooted) and provided that you have an Internet connection, you can get the update from;

Settings -> About watch -> Wireless update.

All you own apps and data will be kept as is.

If you have TWRP installed (and/or possibly rooted) back up everything apps, data, etc with an apk from Play Store (Titanium, My Backup, etc.).

Reinstall V1.3 with SP Flash Tool.

You may want to fully set up your watch at this stage or, alternately, do a minimal set up and do a full set up after updating

Install V1.4 via the Wireless update.

Reinstall TWRP (and root if relevant)

Restore your back up.

I would like to root with magisk, i would like to wait for the new downloadible rom to extract the boot.img , to patch.

if you have twrp on the watch you can install magisk from there instead. In magisk manager you choose to just download the zip instead of updating the boot.img, then in twrp you choose install and find the downloaded zip file

How does it get to zeblaze thor 4 dual MTK6739?

1 Like