Ok google

How can I activate ok google in cospet watch?
Without using app “voice search”?

settings language input many options there

You have to download the Google Assistant, then train it for your voice if you want voice activation without opening the app first.

Feb 24, 2019 11:51:56 GMT Earth said:


How can I activate ok google in cospet watch?
Without using app “voice search”?
I’m not 100% sure but I would think this would be a big drain on your battery. The app will be active all the time listening for your voice. 

No it’s not a big drainer whatsoever. My battery life is 20-36 hr/charge

Thank you all

I have updated Google to the latest version but cannot locate the Google Assistant on my watch at the PlayStore. Any ideas?

@bman98 you can try installing the apk after downloading it here: https://www.apkmirror.com/apk/google-inc/google-assistant/google-assistant-0-1-187945513-release/google-assistant-0-1-187945513-android-apk-download/

I think I made a video about this, have you checked the YT channel?

I downloaded the Google assistant app and installed it on the watch. But it’s still not working in all windows, only the voice search app. When launching the assist app, it says that the watch can’t run the software, it missing something!

Google assistant and OK Google will only work correctly on the 3gb/32gb Kospet Hope and you have to go into settings and allow the Google apps data access at all times for it to work. This is because the Assistant app requires minimum of 2gb ram otherwise it does not show up as available in the Play Store.
Once installed you can follow the instructions in the YouTube video on our channel and also set up the assistant

1 Like

I use Google assistant to play music when I’m Bluetoothed to my car. There’s a significant delay between me asking “hey Google, play music” to when it finally plays, compared to when I ask the same on my smartphone which is much quicker to play. Just wondering if there’s a setting I’ve missed or if there’s something I’m not quite doing right

Its probably because the phone has better hardware than the watch. If you look at antutu scores, the kospet hope has about 30 000 while most newer smartphones has well over 100 000.

1 Like

That’s very odd.
I do exactly the same thing and I don’t experience a long delay.
Maybe go through the voice settings and retrain your voice print in the app.

no luck getting google assistant voice activated on optimus pro

It works well.
Have you looked at the video on our YouTube channel?

i did, looks a bit different on my watch but I think I did all as suggested,
however, the voice recognition option is greyed out and can not be switched on

Ok, I have a confirmed solution for you guys. @fuuz
Since i ran into exactly this problem yesterday.

Make sure you have the assistant installed. and go to your Play Store and search “Google” And open the page for the Google, app. The actual google app.

this one.

And uninstall it. It won’t remove it. It’ll just uninstall the updates. Then on your watch/phone. Go into the Google, app. The one just marked as Google.
Make your way into the settings and enable the Ok Google settings. It will likely look a bit different than the newer versions. It was in the Voice settings for my phone, and i forgot where it was on my kospet hope.

Then go into your Google Assistant and go through it’s internal set up. If it asks you to update your Google app. That’s fine. Go ahead. go to the play store and update it. Just remember to enable the Ok Google settings on the older version first.

Now your google assistant should respond normally.

Here’s the catch. Do NOT go into your Google app settings where you would enable the Access on Voice Match. We’re grandfathering in the settings from the older version.

Edit: Sometimes when the Google app updates it breaks it again. Just noticed. It’s pretty hit’n’miss.
For my kospet hope, updating the Google app breaks it. But the default version is fully featured anyways. Soo… Just be sure to grab the offline voice recognition packs and such. :smiley: I’d give a video tutorial. But OMG that would be a PITA.

How i discovered this fix. I some how broke my assistant last night while looking at my settings just trying to figure out how to get it to work on a phone. And this was how i managed to fix it. I also got Google Assistant working on a phone that doesn’t even support Google Assistant. So you MAY be able to side load it onto a Hope Lite (install with APK), and get it working with this method.

2 Likes

Ok i have a follow up! The fix gets even better! @fuuz @pablo11

After doing the previous steps. Do not update your Google app, regardless. Just uninstall your updates.
Instead, you will download this version of the Google app, it doesn’t have to be this EXACT version, but this one seems to be working well for me. Somewhere in the 8.5x range. Maybe 8.6, or 8.7.
However 8.91 does not work.

https://google-quick-search-box.en.uptodown.com/android/download/1993264

This is the one i used. I picked it at random. I needed it higher than my Hope’s 7.18 default. But lower than 10.x, 9.x, and 8.91. The reason being, is i wanted Google Lens to work, and Lens didn’t work with 7.18.

So this version, 8.55.6.21.arm, works with the Google Assistant. Works with Access with Voice Match.
Works with Google Lens, and Google Translate.

When updating your apps in the play store, just make sure you don’t update the google app. Keep the APK on your watch just incase you ever need to uninstall the Google app and reinstall this middle version.

Please feel free to play around and find higher versions above 8.55 that work. For all i know, 8.70 works, but 8.91 doesn’t.
https://google-quick-search-box.en.uptodown.com/android/versions

So if you find a better version. Keep me updated and I’ll do the same for you.

5 Likes

Thankyou for all the time and effort you have put into this . Its appreciated :+1:

1 Like