LEM8 Drivers issue

Hi, does anyone has correct usb drivers for this watch?

My system: Windows 10 x64
My watch firmwate: Android 7.7 Stock Rom V1.5

I tried various usb mtk drivers, doing stuff with registry and .inf files, but without aby results.
Everytime Windows says I don’t have correct drivers. (Code43, Code 10, USB Drivers decryption fail etc)

Have you followed our video ?
https://www.youtube.com/watch?v=7jv20hVqSZs

Yes, and the problem still occurs.

I use these drivers for the SP Flash Tool

https://mega.nz/#F!MLRnRapQ!Iib1p6dAIu37OWLrfid0ZA

@Vespian, you are just trying to transfer files between the watch and the computer, right? Have you remembered to switch from charging only to mtp after connecting the watch?The drivers should have installed automatically(given that you have an internet connection). Try doing as in the video but select to search automatically for the driver instead of picking it yourself.

I don’t even have the popup when I’m inserting my cable. When I manually set up type of connection (MTP, PTP, etc), the options are either grayed out or turn on but do nothing new :confused:

Didn’t worked for me :confused: And to add to it, I even tried MTK drivers. Both in normal mode and with disabled drivers signed enforcement.