Automatic Bluetooth Internet Tethering

I recently got a Kospet Optimus Pro and wanted to be able to use it for online tasks while on the go (checking email, weather, etc).

But I found that turning on BT internet tethering caused a large amount of battery drain on the watch, even when doing nothing else (around 45% in 8hrs).

I decided to look for a way to have tethering only activate when the display was on.
After a bit of searching I found a thread on XDA that showed how to do just that via tasker.

XDA Thread
https://forum.xda-developers.com/showthread.php?t=2573207

Tasker

Bluetooth Auto Connect

You need to install tasker and Bluetooth auto connect and then follow the instructions on the XDA thread to create tasker profiles to turn tether on and off.

I found it worked better on my watch with the initial wait time set to 5 seconds rather than 20 as suggested so that it is close to the backlight timeout.

After setting this up I only loose 13% over 8hrs (with the watch doing nothing else) and when I unlock the display BT tether auto-activates in a few seconds and I have internet access without the constant battery drain, or having to mess around in the BT menu.

I hope this helps others get better battery life from their watches :slight_smile:

6 Likes

Please correct me if im wrong.

As a newbee in smartwatch world I need to ask the question.

What’s the point to use bletooth internet tethering if in simple way i can just turn on hotspot on my mobile?:nerd_face:

Cheers!
Tomasz

Pretty sure the power consumption for BT tethering is less than the power consumption of hotspot mode.

Plus BT tether is to a single device rather than making the phone into a visible wifi hotspot.

Good points but I would also consider that your phone has an 4 or 5Kmah battery vs a 400 to 600mah battery (average) in your watch.
Plus you can charge your phone on the go while your watch is less mobile. A hotspot still requires a password to use it.

1 Like

True, all this made me a different way of thinking.

Specially, that the internet connection is really active when the screen is on.
And safety reasons of course.

hello,

id love to implement this battery saving solution, although i would need to get my watch to Bluetooth internet tether properly first.

when using the phone under Bluetooth internet access i click the “internet access” toggle but get “cant use bluetooth tethering while connected to wifi network”. then i turn wifi off on the phone, but when the same toggle is clicked on, it immediately turns itself off with no error, no internet.

from the watch i navigate to settings > connect > bluetooth > paried devices > select my phone > system cog wheel > doesnt even have an internet sharing option to click???

phone samsung Galaxy A5 (2017) running android 8, 5 gig mobile data a month
kospet optimus pro FW v 2.5

That’s odd. You should have an “Internet Access” checkbox on the watch in the bluetooth menu (where you described). It should be just above the “Contact Sharing” tick box.

You may need to enable BT tethering on the phone first. Have a look on the phone under settings > more settings > bluetooth tethering.

If that doesn’t help I’d try un-pairing and re-pairing the BT connection.

i appreciate your help, i was wondering why i see the option there on my phone and click it on, but it simply wont stay active.

I will try to un-pair and re-pair the phone and watch together, but also “forget” the connection and start again from scratch, gonna give it a try now.

i’ve tried every possible combination i know of. still no success.

phone wont let me enable BT internet tether (even though the toggle is there)
watch wont let me even see an “internet access” checkbox under BT menu

thanks anyway reichstien, we tried

My Samsung S7 Active is the same way. It is there but won’t let me activate it. I wonder if it is a carrier based issue. AT&T places several restrictions on their Unlimited Data plans. This may be another one.

i hope that’s not the case although i wouldn’t put it past the carriers to implement something like that, they do alot of those cheeky moves up here in Canada with our carriers as well.

It’s too bad Canadian Mobile companies can’t supply the price and data that Australian mobile phone companies give, For $65/month you get 125GB of data at max speed 4G/LTE then it gets capped. But here in Canada, you get 10GB of data at max speed and then throttled for $75/month. but that’s a whole other corporate monopoly issue.

in regards to the BT internet tether, i will keep trying things. for anyone else experiencing the same problem feel free to post here and keep the thread alive until we find a viable solution. could just be something simple that we are neglecting.

Did you go into settings > more settings > bluetooth tethering (on the phone, not the watch) and enable it there before you tried to enable it via the BT menu on the watch?

I have found that if I don’t do that, when I enable “internet access” on the watch it immediately turns off again.

i have tried exactly that, yet no success.

Dang, I was hoping that was it.

At this point I’d be searching online to see if others have had similar issues with other Android devices.
There may be a known cause.

thanks for your attention, i will continue to research cause.

for quick workaround there is always wifi hotspot although much more considerable battery drain vs low power bluetooth. BT would be all day solution, wifi is recommended to toggle on and off, or pop in SIM card.

Sorry if this is restating stuff you already know but I was just re-reading this thread and there was something that I’m not sure was entirely clear.

When you go into the BT menu on the phone and select the smartwatch and then tick the “internet access” checkbox, what the phone is trying to do is get it’s internet from the watch, this is not what we want to do. That’s why it complains about you already being connected to a WiFi network.

The “internet access” tick box needs to be checked on the watch, not the phone.

Again, sorry if you had already realised this, but I figured better safe than sorry and it can’t hurt for it to be in here twice for anyone else reading the thread with similar issues.